Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Some turbo/tuning knowledge help

  1. #11
    Forum Member furian76's Avatar
    Join Date
    May 2008
    Posts
    1,539

    Default

    With new tune installed, replaced oil pump as it died, it now has a nice idle and does not limp mode at idle speed so far.

    After a few soft runs that spun a limp mode with zero codes or reference info, we think we found the culprit. Shift points. There must be some sort of safety built in some where that when the vehicle shifts, it will over rev slightly. But that over rev is sending the TCM into panic mode. So we backed the RPM range down and that feels like it fixed 70% of the issues. We still have a WOT limp mode issue and a limp mode above 80mph in 4th. But it feels like it could be a programming issue.

    Final part is temperature. This thing does not like the cold. Throttle response is super laggy from a standing position to slow roll and it stutters until the temps warm up. Then it runs like a champ. And when full boost is reach at 7psi, I have to remember that just because my foot is off the gas, it doesn't mean the car is ready to slow down!

  2. #12
    Forum Member furian76's Avatar
    Join Date
    May 2008
    Posts
    1,539

    Default

    Update: So after many months of replacing parts (at the shops expense) they reset the tune back to stock. They thought maybe because they tuned it with the transfer case disconnected on a dyno, that maybe there is something there. Turned out, that is true. They have since did a street tune instead of a dyno tune on it. Zero stutter, no codes, no limp mode, and they said it feels noticeably faster than before. They have it for a few more days of driving it to make sure it gets a thorough shake down, but it sounds like the mystery is literally the programming of the TCM. I am just glad they figured it out without anything breaking and without costing my additional money.

    I plan to take it to Louisville for an AWD dyno day to get some final numbers and review input. I will post up once it al that gets done.

  3. #13
    Club Member mustangmike6996's Avatar
    Join Date
    Aug 2007
    Location
    Mt Clem (the nice part)
    Posts
    6,743

    Default

    That's pretty odd, glad they got it sorted out.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •